QNAP meldt meerdere kwetsbaarheden in software voor zijn nas-systemen verholpen te hebben, waaronder in de Qusbcam2-software. Ook switches van het bedrijf die QuNetSwitch draaien, waren kwetsbaar.

QNAP meldt in een beveiligingswaarschuwing dat Qusbcam2 een kritieke bufferoverflowkwetsbaarheid had die aanvallers konden uitbuiten om zo willekeurig code op kwetsbare systemen uit te voeren. Het probleem is verholpen bij Qusbcam2 1.1.4 op QTS 4.5.4, QTS 4.3.6 en QuTS h4.5.3 en latere versies. De software maakt het mogelijk een externe camera op een nas-systeem aan te sluiten en het beeld op afstand te bekijken...

....twee stackbufferoverflowproblemen van NVR Storage Expansion zijn verholpen bij versie 1.0.6 en latere versies van deze software voor video-opnames via netwerken. Ten slotte is een kwetsbaarheid verholpen in de QSW-M2116P-2T2S en QNAP-switches die QuNetSwitch draaien. Deze maakte het uitlezen van gevoelige data mogelijk.

Alles bij de bron; Tweakers



Abonneer je nu op onze wekelijkse nieuwsbrief!
captcha